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Установка программного обеспечения 

Установка среды CoDeSys 

1. Для работы с ПЛК SystemePLC необходимa IDE CoDeSys. 

Скачать и установить на ПК версию CoDeSys 3.5 SP Patch 6. 

Ссылка для скачивания:  
https://workspace.systeme.ru/s/a45pBGfEnXoqLFE 

Установка target-файлов устройств 

1. Для работы с SystemePLC необходимо скачать и установить target-файлы и 
библиотеки.  
Ссылка для скачивания:  

https://workspace.systeme.ru/s/rMyqeta7SbQNizo 

2. После установки файлов, запустите среду CoDeSys. В панели инструментов 

выберете пункт 

Tools > Device Repository 

 

 
 

3. В открывшемся диалоговом окне можно добавлять новые устройства. Для этого 
нажмите «Install». 

https://workspace.systeme.ru/s/a45pBGfEnXoqLFE
https://workspace.systeme.ru/s/rMyqeta7SbQNizo
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4. В открывшемся меню перейдите к папке с установленными ранее target-файлами 

и поочередно установите каждое устройство. 

 

 
 

5. После добавления каждого из устройств, новые устройства можно увидеть в 
списке устройств. Проверьте, правильно ли были установлены все файлы. Для 
этого можно воспользоваться фильтром по вендору выбрав пункт 

Vendor > Systeme Electric  
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Установка библиотек  
1. Организации обмена данными по протоколу Modbus RTU/TCP, возможна с 

помощью функциональных блоков из библиотеки “Systeme Electric Modbus_Vx.x” 
Для добавления необходимых библиотек, с помощью панели инструментов 
выберите пункт 

Tools > Library Repository 

 

 
 

2. В открывшемся диалоговом окне можно добавлять новые устройства. Для этого 
нажмите «Install». 
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3. В открывшемся меню перейдите к папке с установленными ранее файлами 
библиотек и поочередно установите каждую из них. Если в папке не 
отображаются необходимые файлы библиотек, проверьте фильтр по 
расширениям. 
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4. После добавления каждого из устройств, новые устройства можно увидеть в 
списке устройств. Проверьте, правильно ли были установлены все файлы. Для 
этого можно воспользоваться фильтром по компаниям выбрав пункт 

Company > Systeme Electric  

 

 

Настройки проекта 

Создание нового проекта 

После установки всех необходимых компонентов можно приступить к работе с 
контроллерами Systeme Electric серии SM252 и SM253 в среде CoDeSys. 

1. Для создания нового проекта выберите пункт  
File > New Project  (горячая клавиша Ctrl+N ) 
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2. В открывшемся окне выберите шаблон, укажите имя и путь к месту сохранения 
файлов проекта. Нажмите "ОК" для сохранения введенных данных, будет запущен 
диалог создания нового проекта. 

 

 
 

3. В диалоговом окне создания проекта в выпадающих списках будут предложены 

выбор контроллера и языка программирования, на котором будет описана 
программа.  
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Добавление библиотеки Modbus в проект 

1. В библиотеке доступны функциональные блоки для организации обмена данных 
по протоколу Modbus RTU/TCP в режиме Master/Slave для порта RS485 или 
Client/Server для порта Ethernet. Для начала работы с библиотекой Modbus 

необходимо добавить её в ранее созданный проект. Для этого откройте окно 

Library Manager > Add library 

 

 
 

2. В открытом диалоговом окне выберите библиотеку «Systeme Electric Modbus 

Library» для добавления её в свой проект. 
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3. После добавления библиотеки становятся доступными функциональные блоки 
для работы с контроллером по протоколу Modbus. 

 

 
Функциональные блоки с индексом “_1” для данных моделей ПЛК SM252/SM253 не 

используются 
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Работа с библиотекой Modbus 

Объявление глобальных переменных 

Прежде чем приступить к работе с функциональными блоками необходимо объявить 
глобальные переменные для более простого доступа к конфигурации параметров 
работы с протоколом. 
1. Для создания списка с глобальными переменными в проекте, из меню выберете 

Project > Add Object > Global Variable List  

 

 
 

2. В диалоговом окне укажите название для созданного списка 
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3. Добавьте следующие переменные (по одной из группы для каждого 
функционального блока) 

 

VAR_GLOBAL 

 (* Переменные для области памяти регистров входов в режиме 
Slave/Server*) 

  Input_iVar1 AT %IW0 : INT; 

  Input_iVar2 AT %IW1 : INT; 

  Input_iVar3 AT %IW2 : INT; 

 (* Переменные для области памяти регистров хранения в режиме 
Slave/Server *) 

  Holding_iVar1 AT %MW0 : INT; 

  Holding_iVar2 AT %MW1 : INT; 

  Holding_iVar3 AT %MW2 : INT; 

 (* Переменные для считываемых /записываемых данных по Modbus в 
режиме Master/Client*) 
  ReadMdb_iVar1 AT %MW0 : INT; 

  ReadMdb_iVar2 AT %MW1 : INT; 

  ReadMdb_iVar3 AT %MW2 : INT; 

END_VAR 

 

В примере выше объявлены по 3 глобальных переменных для каждой из областей 
памяти для доступа по Modbus RTU 

 

Общая настройка 

1. Для начала работы с блоком создайте новый POU-элемент (Program Organization 

Unit) путем выбора из меню 

Project > Add Object > POU  
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2. В вызванном диалоговом окне укажите название файла и язык 
программирования 

 
 

3. После проделанных действий будет открыто окно редактирования программы на 
ранее выбранном языке. Для добавления функционального блока из меню 
выберите  
FBD/LD/IL > Insert Box (горячая клавиша Ctrl + B ) 
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4. Будет вызвано окно выбора функционального блока, в котором можно выбрать 

необходимый блок. Для этого в категории «Functional blocks» раскрыть список 
блоков из библиотеки «Systeme_Electric_Modbus_RTU_and_TCP» и выбрать 
нужный блок. 

 

 
Выбор блока и дальнейшие действия более подробно описаны ниже для каждого 

варианта работы 
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Добавление программ в список вызываемых задач 

После создания новых объектов POU, необходимо добавить их в список вызываемых 
в созданных задачах. 
1. Для этого в дереве проекта, выберите пункт 

Task Configuration > Main Task 

 

 
2. Добавить новую программу в список вызываемых в указанной задаче можно 

осуществить с помощью «Add Call». 

3. В открывшемся окне выбрать нужную программу из списка созданных в проекте. 
Добавленные задачи будут загружены на ПЛК во время подключения 
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Работа в режиме Modbus Slave 

Для работы с протоколом Modbus в режиме Slave используется функциональный блок 
«MBUS_INIT».  

1. После выбора блока «MBUS_INIT» будет создан экземпляр функционального блока 
со следующими характеристиками: 

Таблица входов MBUS_INIT 

Название Описание Значения 

Mode Режим работы 0 – выключен, 1 – включен 

Addr Адрес устройства в сети Modbus От 1 до 247 

Baud Скорость обмена данными 1200, 2400, 4800, 9600, 19200, 

38400, 57600, 115200 

Parity Проверка бита четности  0 – нет, 1 – нечетный, 

2 – четный 

Delay Задержка ответа в мс По умолчанию- 0. Изменяется 
в зависимости от задачи 

Inputs Указатель на первую переменную 
для области памяти регистров 
входов (Input registers) 

(Переменные, которые будут 
доступны по 4-й функции Modbus) 

Адрес ранее созданной 
переменной Input_iVar1 в 
виде: ADR(Input_iVar1) 
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InputSize Количество переменных в 
области памяти Input 

 

Outputs Указатель на первую переменную 
для области памяти регистров 
хранения (Output registers) 

(Переменные, которые будут 
доступны по 3-й функции Modbus) 

Адрес ранее созданной 
переменной Holding_iVar1 в 
виде: ADR(Holding _iVar1) 

OutputSize Количество переменных в 
области памяти Holding 

 

 

Таблица выходов MBUS_INIT 

Название Описание Значения 

Done Состояние работы блока 0 – Процесс выполняется 

1 – Процесс завершен 

Error Коды ошибок 0 – Нормальная работа 
(ошибок нет) 
1 – Ошибка диапазона памяти 

2 – Недопустимая скорость 
передачи/паритет 

3 – Недопустимый адрес 
ведомого устройства  
4 – Недопустимый протокол 
(параметр Modbus) 
5 – Регистры хранения 
перекрывают буферы Modbus 

6 – Ошибка паритета входного 
сигнала 

7 – Ошибка запроса 
получаемого сигнала 

8 – Ошибка вызова функции 

9 – Недопустимый адрес 
памяти в запросе 

10 – Протокол Modbus не 
инициализирован 
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В соответствии с таблицей входов выше, можно заполнить данные для работы блока 

 

2. Далее необходимо добавить 2 переменные для выходов функционального блока: 

«xDone», которая отображает состояние работы блока и «byErrorCode», которая 
будет хранить значение кода ошибки. Для этого необходимо выбрать контакт 
«Done» и из контекстного меню выбрать «Insert Coil». 
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3. После этого будет создана катушка без указанной переменной. Для того, чтобы 
добавить новую переменную, введите новое значение, после чего будет вызвано 
диалоговое окно автоматического определения переменной. 
 

 
Таким же образом можно добавить переменную «byErrorCode» 

 

4. Таким образом, связь с ПЛК по сети Modbus в режиме Slave доступна по 
интерфейсу RS485 со скоростью передачи данных 9600, и адресом ПЛК в сети 
Modbus- 10. Входные данные записываются в область памяти, начиная с 
Input_iVar1, выходные –  начиная с Holding_iVar1. 
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Работа в режиме Modbus Master 

Для работы с протоколом Modbus в режиме Master используется 2 функциональных 
блока: «MBUS_CTRL» и «MBUS_MSG» для настроек параметров обмена и для 
чтения/записи данных по сети Modbus RTU соответственно.  

 

1. После выбора блока «MBUS_CTRL» будет создан экземпляр функционального 
блока со следующими характеристиками: 

Таблица входов MBUS_CTRL 

Название Описание Значения 

Mode Режим работы 0 – выключен, 1 – включен 

Baud Скорость обмена данными 1200, 2400, 4800, 9600, 19200, 

38400, 57600, 115200 

Parity Проверка бита четности  0 – нет, 1 – нечетный, 
2 – четный 

Timeout Время ожидания ответа в мс. 

Если ведомый узел не отвечает на 
данные в течение установленного 
времени, это считается задержкой 

чтения/записи 

 

 

Таблица выходов MBUS_CTRL 

Название Описание Значения 

Done Состояние работы блока 0 – Процесс выполняется 

1 – Процесс завершен 

Error Коды ошибок 0 – Нормальная работа 
(ошибок нет) 
1 – Ошибка верификации 

2 – Ошибка скорости 
передачи данных 

3 – Ошибка истечения 
времени ожидания 

4 – Ошибка запроса 

5 – Шина не включена 

6 – Ошибка доступа к 
устройству. Связь уже 
используется другим 
процессом 

7 – Ошибка ответа 

8 – Ошибка CRC (Cyclical 

Redundancy Check) 

9 – Аппаратная ошибка 
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Аналогично создается экземпляр блока «MBUS_MSG» со следующими 
характеристиками: 

Таблица входов MBUS_MSG 

Название Описание Значения 

First Запрос на обмен. Выполняется 
каждый раз, когда контакт 
активируется 

0 – выключен, 
1 – включен 

Slave Адрес ведомого устройства, с 
которым осуществляется обмен в 
сети Modbus 

От 1 до 247 

RW Тип запроса 0 – запрос на чтение данных, 
1– запрос на запись данных 

Addr Начальный адрес с данными для 
чтения/записи 

Такие как 30001, 40001, … 

Count Количество байт для 
чтения/записи от начального 
адреса 

От 0 до 120 слов 

DataPtr Указатель на область памяти для 
размещения считываемых/ 
записываемых данных  

Адрес ранее созданной 
переменной ReadMdb_iVar1 в 
виде ADR(ReadMdb_iVar1) 

 

Таблица выходов MBUS_MSG 

Название Описание Значения 

Done Состояние работы блока 0 – Процесс выполняется 

1 – Процесс завершен 

Error Коды ошибок 0 – Нормальная работа 
(ошибок нет) 
1 – Ошибка верификации 

2 – Ошибка скорости 
передачи данных 

3 – Ошибка истечения 
времени ожидания 

4 – Ошибка запроса 

5 – Шина не включена 

6 – Ошибка доступа к 
устройству. Связь уже 
используется другим 
процессом 

7 – Ошибка ответа 

8 – Ошибка CRC (Cyclical 

Redundancy Check) 

9 – Аппаратная ошибка 
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В соответствии с таблицами входов выше, можно заполнить входные данные для 

работы блоков MBUS_CTRL и MBUS_MSG 

 

2. Далее, по аналогии с настройкой для блока «MBUS_SLAVE», необходимо добавить 
по 2 переменные для выходов функционального блока «MBUS_CTRL» и 
«MBUS_MSG»: «xDone1» и «xDone2», которые отображают состояние работы 
блоков и «byErrorCode1» и «byErrorCode2» соответственно, которые будут 
хранить значение кода ошибки.  

Также перед блоком «MBUS_MSG» необходимо добавить контакт для отправки 
запроса на чтение/запись «xCmdRequest».  
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3. Таким образом, связь с ПЛК по сети Modbus в режиме Master доступна по 
интерфейсу RS485 со скоростью передачи данных 9600, и адресом Slave-ПЛК в 
сети Modbus- 5. При получении сигнала с «xCmdRequest» происходит процесс 
чтения 3 слов начиная из адреса 30001 и сохранение в глобальных переменных в 
памяти начиная с адреса «ReadMdb_iVar1» 

 

 
 

 

Работа в режиме Modbus TCP Server 

Для работы с протоколом Modbus TCP в режиме Server используется 
функциональный блок: «MBUS_TCP_SLAVE». По настраиваемым параметрам он 
идентичен блоку «MBUS_INIT», используемый для работы с протоколом Modbus RTU 

Slave. 

1. После выбора блока «MBUS_TCP_SLAVE» будет создан экземпляр 
функционального блока со следующими характеристиками: 
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Таблица входов MBUS_TCP_SLAVE 

Название Описание Значения 

Mode Режим работы 0 – выключен, 1 – включен 

Port Порт сервера По умолчанию- 502 

Unit Адрес Modbus сервера или адрес 
устройства в сети RS-485 при 
обмене через шлюз  
Ethernet - RS-485  

По умолчанию- 1 

Delay Задержка ответа в мс По умолчанию- 0. Изменяется 
в зависимости от задачи 

Inputs Указатель на первую переменную 
для области памяти регистров 
входов (Input registers) 

(Переменные, которые будут 
доступны по 4-й функции Modbus) 

Адрес ранее созданной 
переменной Input_iVar1 в 
виде: ADR(Input_iVar1) 

InputSize Количество переменных в 
области памяти Input 

 

Outputs Указатель на первую переменную 
для области памяти регистров 
хранения (Output registers) 

(Переменные, которые будут 
доступны по 3-й функции Modbus) 

Адрес ранее созданной 
переменной Holding_iVar1 в 
виде: ADR(Holding _iVar1) 

OutputSize Количество переменных в 
области памяти Holding 

 

 

Таблица выходов MBUS_TCP_SLAVE 

Название Описание Значения 

Done Состояние работы блока 0 – Процесс выполняется 

1 – Процесс завершен 

Error Коды ошибок 0 – Нормальная работа 
(ошибок нет) 
1 – Ошибка диапазона памяти 

2 – Недопустимая скорость 
передачи/паритет 

3 – Недопустимый адрес 
ведомого устройства  
4 – Недопустимый протокол 
(параметр Modbus) 
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5 – Регистры хранения 
перекрывают буферы Modbus 

6 – Ошибка паритета входного 
сигнала 

7 – Ошибка запроса 
получаемого сигнала 

8 – Ошибка вызова функции 

9 – Недопустимый адрес 
памяти в запросе 

10 – Протокол Modbus не 
инициализирован 

 

2. В соответствии с таблицами из предыдущего пункта можно заполнить данные для 
работы функционального блока «MBUS_TCP_SLAVE». Таким образом, полученный 
блок позволяет запустить Modbus TCP Server на ведомом устройстве с адресом «1» 
с портом «502». Входные данные записываются в область памяти, начиная с 
Input_iVar1, выходные – начиная с Holding_iVar1. 
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Работа в режиме Modbus TCP Client 

Для работы с протоколом Modbus TCP в режиме Server используется 
функциональный блок: «MBUS_TCP_REQ». По настраиваемым параметрам он 
идентичен блоку «MBUS_MSG», используемый для работы с протоколом Modbus RTU 

Slave. 

1. После выбора блока «MBUS_TCP_REQ» будет создан экземпляр функционального 
блока со следующими характеристиками: 

Таблица входов MBUS_TCP_REQ 

Название Описание Значения 

Mode Режим работы 0 – выключен, 1 – включен 

IP Адрес опрашиваемого устройства IP-адрес устройства, на 
котором запущен Modbus 

Server типа ‘192.168.0.1’ 
Port Порт TCP-сервера По умолчанию- 502 

Unit Адрес Modbus сервера или адрес 
устройства в сети RS-485 при 
обмене через шлюз  
Ethernet - RS-485  

По умолчанию- 1 

RW Тип запроса 0 – запрос на чтение данных, 
1– запрос на запись данных 

Addr Начальный адрес с данными для 
чтения/записи 

Такие как 30001, 40001, … 

Count Количество байт для 
чтения/записи от начального 
адреса 

От 0 до 120 слов 

DataPtr Указатель на область памяти для 
размещения считываемых/ 
записываемых данных  

Адрес ранее созданной 
переменной ReadMdb_iVar1 в 
виде ADR(ReadMdb_iVar1) 

 

Таблица выходов MBUS_TCP_REQ 

Название Описание Значения 

Done Состояние работы блока 0 – Процесс выполняется 

1 – Процесс завершен 

Error Коды ошибок 0 – Нормальная работа 
(ошибок нет) 
1 – Ошибка верификации 

2 – Ошибка скорости 
передачи данных 

3 – Ошибка истечения 
времени ожидания 



   

 

28 

 

4 – Ошибка запроса 

5 – Шина не включена 

6 – Ошибка доступа к 
устройству. Связь уже 
используется другим 
процессом 

7 – Ошибка ответа 

8 – Ошибка CRC (Cyclical 

Redundancy Check) 

9 – Аппаратная ошибка 

 

2. В соответствии с таблицами из предыдущего пункта можно заполнить данные для 
работы функционального блока «MBUS_TCP_REQ». Таким образом, полученный 
блок позволяет запустить Modbus TCP Client. 
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Сетевые настройки ПЛК 

Настройка параметров сети для работы с ПЛК 

Прежде чем приступить к конфигурации параметров в среде Codesys, необходимо 
задать параметры сети персонального компьютера. 

1. Для перехода к настройке параметров, перейдите во вкладку  
Control Panel > Network and Internet > Network Connections 

Панель управления > Сети и Интернет > Изменение параметров адаптера 

 

 
В открывшемся окне появится список сетевых устройств и интерфейсов.  
Выберите то, с помощью которого осуществляется подключение к ПЛК 

 

2. В открывшемся меню параметров, выбрать настройку соединения с помощью 
«Internet Protocol Version 4 (TCP/IPv4)» 
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3. Установить указанные ниже параметры сети и сохранить настройки. IP-адрес 
может принимать значения в диапазоне 192.168.0.3 - 192.168.0.255 и маску 
подсети 255.255.255.0 . 
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Настройка интерфейса  

Для осуществления связи ПК с контроллером необходимо добавить в дерево проекта 
устройство для конфигурации параметров сети – «Ethernet Adapter». 

1. Для добавления нового устройства, перейдите к дереву объектов проекта, 
выберите настраиваемый ПЛК, например SM252, и вызвав контекстное меню, 
выберите пункт «Add Device». 

  

 
 

2. В открывшемся окне, выбрать пункт 

Fieldbusses > Ethernet Adapter > Ethernet 

После чего, можно добавить устройство в проект, нажав «Add Device» 
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3. Убедитесь, что ПЛК подключен к ПК с помощью Ethernet-кабеля.  

Перейдите к настройке интерфейса, нажав на «…». В открывшемся меню выберите 
сетевой адаптер со следующими параметрами 

 
Текущие параметры сети основаны на введенных ранее данных 
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4. После установки параметров, можно приступить к подключению к ПЛК с 
помощью среды Codesys. Для этого перейдите к настройкам контроллера из 
дерева проекта. 

 
5. В открывшейся вкладке, выполните поиск устройств в подключенной сети с 

помощью «Scan Network» 
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6. Если настройка была произведена верно, в списке устройств в указанной сети 
можно будет найти нужный ПЛК. 

 
 

7. После добавления контроллера, изменится состояние индикатора, отображающее 
состояние подключения. Это значит, что контроллер успешно подключен и 
возможна дальнейшая работа с устройством. 
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Изменение IP-адреса устройства 

1. По умолчанию ПЛК имеет IP-адрес 192.168.0.2. Для изменения сетевых настроек 
ПЛК необходимо перейти к настройкам устройства в дереве проекта. 

 

 
 

2. Перейти в «PLC Shell» для настройки внутренних параметров контроллера. Для 
изменения IP-адреса контроллера используется команда «setip», которая 
принимает в качестве параметра новый IP-адрес. Например: при вводе ‘setip 

192.168.0.10‘ , IP-адрес поменяется на 192.168.0.10.  

 

Для более подробного описания всех команд, в том числе «setip», отправьте в 
командную строку символ «?».  
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